Erreur lors de l'auto import (import en masse)

L'import en masse pour les applications Maarch
Mass Import for Maarch Applications

Erreur lors de l'auto import (import en masse)

Message par kkmoda81 » 15 Juil 2013, 13:32

Voici dessous le contenu de mon fichier autoimport_entreprise_scan.sh

php /var/autoimport/maarch_autoimport/maarch_auto_import.php /var/autoimport/data/conf/config_entreprise_scan.xml


Voici dessous le contenu de mon fichier config_entreprise_scan.xml


<ROOT>
<CONFIG>
<CONFIG_NAME>entreprise</CONFIG_NAME>
<MAPPING_FILE>/var/autoimport/data/mapping/mapping_entreprise_scan.xml</MAPPING_FILE>
<SCAN_IMPORT_DIRECTORY>/var/autoimport/incoming/documents/</SCAN_IMPORT_DIRECTORY>
<LOCATION>localhost</LOCATION>
<DATABASE_PORT>5432</DATABASE_PORT>
<DATABASE>moda</DATABASE>
<DATABASETYPE>POSTGRESQL</DATABASETYPE>
<DATABASEWORKSPACE></DATABASEWORKSPACE>
<USER_NAME>postgres</USER_NAME>
<PASSWORD>postgres</PASSWORD>
<TABLE_NAME>res_letterbox</TABLE_NAME>
<INSERT_MODE>true</INSERT_MODE>
<DOCSERVER_NAME>FASTHD_AI</DOCSERVER_NAME>
<DATE_TIME_FORMAT>YYYY-MM-DD</DATE_TIME_FORMAT>
<AUTO_IMPORT_DIRECTORY>/var/autoimport/maarch_autoimport/</AUTO_IMPORT_DIRECTORY>
<WITHOUT_XML>false</WITHOUT_XML>
<BACKUP_BATCH>true</BACKUP_BATCH>
<BACKUP_FAILED>true</BACKUP_FAILED>
<EXCLUDE_EXISTING_DOCS>false</EXCLUDE_EXISTING_DOCS>
<EXCLUDE_EXISTING_DOCS_FOLDER>duplicate</EXCLUDE_EXISTING_DOCS_FOLDER>
<CONTROL_COMPLETE_FILES>false</CONTROL_COMPLETE_FILES>
<CREATE_FOLDERS>false</CREATE_FOLDERS>
<FOLDERS_TABLE_NAME>folders</FOLDERS_TABLE_NAME>
<FOLDERS_MAPPING_FILE>/var/autoimport/data/conf/mapping_folders.xml</FOLDERS_MAPPING_FILE>
<APP_NAME>MEP</APP_NAME>
<LOG_CONFIG_PATH>/var/www/cciged/apps/maarch_entreprise/xml/log4php.xml</LOG_CONFIG_PATH>
<LOGGER>loggerTechnique</LOGGER>
<LOG_FORMAT>[%ACCESS_METHOD%][%RESULT%][%CODE_METIER%][%HOW%][%WHAT%][%REMOTE_IP%]</LOG_FORMAT>
<!--<PLUGINS>
<plugin>pja</plugin>
</PLUGINS>-->
</CONFIG>
</ROOT>




Voici dessous le contenu de mon fichier mapping_entreprise_scan.xml


<?xml version="1.0" encoding="utf-8"?>
<ROOT>
<MAPPING_FILE>
<ELEMENT>
<COLUMN>SUBJECT</COLUMN>
<VALUE>SUBJECT</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>AUTHOR</COLUMN>
<VALUE>AUTHOR</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>IDENTIFIER</COLUMN>
<VALUE>IDENTIFIER</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>DOC_DATE</COLUMN>
<VALUE>DOC_DATE</VALUE>
<FORMAT>DATE</FORMAT>
<DATE_FORMAT>YYYY-MM-DD HH:II:SS</DATE_FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>SCAN_DATE</COLUMN>
<VALUE>SCAN_DATE</VALUE>
<FORMAT>DATE</FORMAT>
<DATE_FORMAT>YYYY-MM-DD HH:II:SS</DATE_FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>STATUS</COLUMN>
<VALUE>STATUS</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>DESTINATION</COLUMN>
<VALUE>DESTINATION</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>DEST_USER</COLUMN>
<VALUE>DEST_USER</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>IS_INGOING</COLUMN>
<VALUE>IS_INGOING</VALUE>
<FORMAT>string</FORMAT>
</ELEMENT>
<ELEMENT>
<COLUMN>TYPE_ID</COLUMN>
<VALUE>'505'</VALUE>
</ELEMENT>
</MAPPING_FILE>
</ROOT>




Voici dessous le contenu de mon fichier 1.xml (contenant les infos sur 1.pdf)

<?xml version="1.0" encoding="UTF-8" ?>
<ROOT>
<SUBJECT>FACTURE N�ICS-006/2013
MONTANT 5 370 750 F CFA</SUBJECT>
<AUTHOR>IVOIRE CARTES SYSTEMES (ICS)</AUTHOR>
<IDENTIFIER>10042013/svceCOU/001646</IDENTIFIER>
<DOC_DATE>2013-04-09 00:00:00</DOC_DATE>
<SCAN_DATE>2013-04-10 14:01:09</SCAN_DATE>
<STATUS>NEW</STATUS>
<DESTINATION>DAF</DESTINATION>
<DEST_USER>cmorite</DEST_USER>
<IS_INGOING>Y</IS_INGOING>
</ROOT>





MAIS QUAND J'exécute voici l'erreur que j'obtiens alors que tous les droits ont été donnés à tous les utilisateurs sur les différents fichiers à traiter :



/var/serverdoc/ai/


/var/autoimport/incoming/documents/1.xml

- <b>query error</b> -<br /><br />ERROR: invalid input syntax for type timestamp: ""
LINE 1: ...07949b51b0d8f97', 158707, 'pdf', '3', '', '', '', '', '', ''...
^
<br/>query : <textarea cols="70" rows="10">insert into res_letterbox (typist, creation_date, docserver_id, path, filename, offset_doc, fingerprint, filesize, format, work_batch, SUBJECT, AUTHOR, IDENTIFIER, DOC_DATE, SCAN_DATE, STATUS, DESTINATION, DEST_USER, IS_INGOING, TYPE_ID) values('AUTOIMPORT', '2013-07-15 13:55:10', 'FASTHD_AI', '2013#07#3#0000#', '', '', '10bc0c7f100074851e4a9d957d12391f6ea1f6cf6184bf7ee07949b51b0d8f97', 158707, 'pdf', '3', '', '', '', '', '', '', '', '', '', '505')</textarea>


Comme s'il n'arrive pas à récupérer les valeurs dans 1.xml

Quelqu'un peut-il m'aider?
kkmoda81
 
Message(s) : 44
Inscription : 16 Mars 2009, 11:47

Re: Erreur lors de l'auto import (import en masse)

Message par kader » 16 Juil 2013, 15:09

Bonjour,
invalid input syntax for type timestamp
Vérifier vos champs dates.

Librement,
kader
 
Message(s) : 830
Inscription : 11 Oct 2010, 13:01
Localisation : Dakar

Re: Erreur lors de l'auto import (import en masse)

Message par kkmoda81 » 16 Juil 2013, 15:49

kader a écrit :Bonjour,
invalid input syntax for type timestamp
Vérifier vos champs dates.

Librement,


Je ne pensepas que ce soit là le problème, regardez la requête dans le message d'erreur, dans la partie values toutes les valeurs figurants dans le fichier 1.xml n'ont pues être récupérées (voir les parties que j'ai mis en exergue en rouge ci-dessous):

/var/serverdoc/ai/


/var/autoimport/incoming/documents/1.xml

- <b>query error</b> -<br /><br />ERROR: invalid input syntax for type timestamp: ""
LINE 1: ...07949b51b0d8f97', 158707, 'pdf', '3', '', '', '', '', '', ''...
^
<br/>query : <textarea cols="70" rows="10">insert into res_letterbox (typist, creation_date, docserver_id, path, filename, offset_doc, fingerprint, filesize, format, work_batch, SUBJECT, AUTHOR, IDENTIFIER, DOC_DATE, SCAN_DATE, STATUS, DESTINATION, DEST_USER, IS_INGOING, TYPE_ID) values('AUTOIMPORT', '2013-07-15 13:55:10', 'FASTHD_AI', '2013#07#3#0000#', '', '', '10bc0c7f100074851e4a9d957d12391f6ea1f6cf6184bf7ee07949b51b0d8f97', 158707, 'pdf', '3', '', '', '', '', '', '', '', '', '', '505')</textarea>
kkmoda81
 
Message(s) : 44
Inscription : 16 Mars 2009, 11:47

Re: Erreur lors de l'auto import (import en masse)

Message par kkmoda81 » 23 Juil 2013, 20:58

C'est une colle on dirait? Où je suis le seul au monde à avoir ce problème.
kkmoda81
 
Message(s) : 44
Inscription : 16 Mars 2009, 11:47

Re: Erreur lors de l'auto import (import en masse)

Message par Aliraza852 » 20 Oct 2014, 10:43

J'ai trouvé le problème. Mauvais chemin utiliser

Merci à tous
ali
Aliraza852
 
Message(s) : 1
Inscription : 20 Oct 2014, 10:34


Retour vers Maarch AutoImport

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)

cron