ScanSnap connector v2 - Erreur d'exécution '429'

Problèmes d'installation du framework Maarch (pour les versions 2.x)
Installation issues (for 2.x versions)

ScanSnap connector v2 - Erreur d'exécution '429'

Message par electrinfo » 18 Août 2008, 23:40

Hello,

Avec mob ScanSnap S300, après configuration selon le wiki du connecteur, lors du scan d'un document, le logiciel Scansnap lance bien le connecteur Maarch, qui meurt soudain en m'indiquant:

Erreur d'exécution '429'
Le composant ActiveX ne peut créer l'objet.

(seul choix: OK - et évidement plus rien ne se passe)

Quelqu'un a-t-il eu le problème ? serait-ce dû aux logiciels de protection qui tournent sur mon laptop (antivirus avast - Spybot search&destroy) ?

Merci d'avance à celle ou celui qui a de l'info. Si y, je veux bien transmettre des logs un peu plus détaillés si l'application en crée.
++
greg
electrinfo
 
Message(s) : 16
Inscription : 15 Août 2008, 20:09

Re: ScanSnap connector v2 - Erreur d'exécution '429'

Message par lgi » 19 Août 2008, 13:17

Bonjour,

il doit y avoir un des composants VB compris dans l'outil qui ne s'est pas enregistré correctement.
quelle version de Windows avez-vous?

sinon voici une piste pour résoudre le souci :

Erreur d'exécution '429' : Le composant ActiveX ne peut pas créer l'objet :

Vous devez enregistrer correctement le ou les composants incriminés. Pour ce faire, vous devez localiser l'implantation physique de ce composant dans votre système et également dans le Registre de Windows.

Vous devez alors faire en sorte d'avoir une seule et unique version et que cette version soit celle qui corresponde à la version exploitée dans votre projet.


le mieux est de regarder les DLL installées dans c:\windows\system32 par l'outil est de tenter de les enregistrer à la mano avec la commande regsvr32 [path_dll].
Se réveiller, c'est se mettre à la recherche du monde.
lgi
 
Message(s) : 113
Inscription : 12 Déc 2007, 18:58

Re: ScanSnap connector v2 - Erreur d'exécution '429'

Message par electrinfo » 19 Août 2008, 13:53

je suis sous windows XP, je tenterai ce soir de faire tout ça à la main...
electrinfo
 
Message(s) : 16
Inscription : 15 Août 2008, 20:09

Re: ScanSnap connector v2 - Erreur d'exécution '429'

Message par electrinfo » 19 Août 2008, 21:11

hello,

J'ai donc essayé d'enregistrer toutes les dll que j'ai trouvé dans les sources à la main, pour ceux qui devraient le faire, voici le code à sauver dans un .bat pour se simplifier la vie:
Code : Tout sélectionner
regsvr32 "C:\WINDOWS\system32\aamd532.dll"
regsvr32 "C:\WINDOWS\system32\asycfilt.dll"
regsvr32 "C:\WINDOWS\system32\COMCAT.DLL"
regsvr32 "C:\WINDOWS\system32\MSVBVM60.DLL"
regsvr32 "C:\WINDOWS\system32\msvcrt.dll"
regsvr32 "C:\WINDOWS\system32\MSWINSCK.OCX"
regsvr32 "C:\WINDOWS\system32\oleaut32.dll"
regsvr32 "C:\WINDOWS\system32\olepro32.dll"
regsvr32 "C:\WINDOWS\system32\scrrnfr.dll"
regsvr32 "C:\WINDOWS\system32\scrrun.dll"
regsvr32 "C:\WINDOWS\system32\VB6FR.DLL"
regsvr32 "C:\WINDOWS\system32\VB6STKIT.DLL"
regsvr32 "C:\WINDOWS\system32\WINSKFR.DLL"
pause


La plupart sont enregistrées, mais parfois j'ai droit à un message "....dll wal loaded, but the DllRegisterServer entry point was not found. This file can not be registred."

Toujours est-il que maintenant, je n'ai plus l'erreur 429, le connecteur se lance, et ne fais plus rien en prenant toutes les ressources CPU.

Le fichier est par contre bien uploadé car si je vais manuellement sur la page http://serveur/index_scansnap.php, mon nouveau scan apparait dans la liste des fichiers sur le serveur.
electrinfo
 
Message(s) : 16
Inscription : 15 Août 2008, 20:09


Retour vers Installation (Maarch 2.x)

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité