Erreur au premier lancement "L'erreur N1146 vient ..."

Problèmes d'installation du framework Maarch (pour les versions 2.x)
Installation issues (for 2.x versions)

Erreur au premier lancement "L'erreur N1146 vient ..."

Message par yarow » 20 Sep 2008, 01:48

Bonjour,

Au premier lancement de l'aaplication j'ai l'eerur suivante :

L'erreur N1146 vient de se produire
Message : Table 'maarch.USERS' doesn't exist

La base de donnée et la table users existe bien, je fait tourner le tout sur Linux + xampp
le config.xml a été modifié avec mes valeurs (nom de base, user , pwd)

quelqu'un aurait une piste ?
yarow
 
Message(s) : 3
Inscription : 20 Sep 2008, 01:38

Re: Erreur au premier lancement "L'erreur N1146 vient ..."

Message par adiligent » 20 Sep 2008, 09:57

Bonjour,

yarow a écrit :
Au premier lancement de l'aaplication j'ai l'eerur suivante :

L'erreur N1146 vient de se produire
Message : Table 'maarch.USERS' doesn't exist


Probablement un problème de majuscules/minuscules dans le nom de la table qui doit-être respecté sous LINUX.

AD
adiligent
 
Message(s) : 20
Inscription : 27 Mars 2008, 21:34

Re: Erreur au premier lancement "L'erreur N1146 vient ..."

Message par yarow » 20 Sep 2008, 10:18

adiligent a écrit :Bonjour,

yarow a écrit :
Au premier lancement de l'aaplication j'ai l'eerur suivante :

L'erreur N1146 vient de se produire
Message : Table 'maarch.USERS' doesn't exist


Probablement un problème de majuscules/minuscules dans le nom de la table qui doit-être respecté sous LINUX.

AD


oui mais au niveau de la base de données c'est transparent normalement ... non? et puis dans la base les noms de table sont en majuscules
yarow
 
Message(s) : 3
Inscription : 20 Sep 2008, 01:38

Re: Erreur au premier lancement "L'erreur N1146 vient ..."

Message par electrinfo » 20 Sep 2008, 11:41

non je ne pense malheuresement pas que ç a soit identique, il me semble avoir du faire les corrections:

Dans ton xml/config.xml dans la partie es tables, met tout en minuscule:

Voici si jamais ma partie que tu peux copier coller:
Code : Tout sélectionner
        <TABLENAME>                                                       <!-- Noms de tables de la base de données de Maarch-->
                <arboxes>arboxes</arboxes>
                <arcontainers>arcontainers</arcontainers>
                <authors>authors</authors>
                <baskets>baskets</baskets>
                <docservers>docservers</docservers>
                <doctypes>doctypes</doctypes>
                <extdocserver>ext_docserver</extdocserver>
                <fulltext>fulltext</fulltext>
                <groupbaskets>groupbasket</groupbaskets>
                <groupsecurity>groupsecurity</groupsecurity>
                <history>history</history>
                <param>parameters</param>
                <resgroups>resgroups</resgroups>
                <resgroupcontent>resgroup_content</resgroupcontent>
                <security>security</security>
                <usergroups>usergroups</usergroups>
                <usergroupcontent>usergroup_content</usergroupcontent>
                <users>users</users>
        </TABLENAME>


vérifie que tu ais bien la même liste avant d'écraser tout ça ;-)
++
electrinfo
 
Message(s) : 16
Inscription : 15 Août 2008, 20:09

Re: Erreur au premier lancement "L'erreur N1146 vient ..."

Message par yarow » 20 Sep 2008, 12:15

electrinfo a écrit :non je ne pense malheuresement pas que ç a soit identique, il me semble avoir du faire les corrections:

Dans ton xml/config.xml dans la partie es tables, met tout en minuscule:

Voici si jamais ma partie que tu peux copier coller:
Code : Tout sélectionner
        <TABLENAME>                                                       <!-- Noms de tables de la base de données de Maarch-->
                <arboxes>arboxes</arboxes>
                <arcontainers>arcontainers</arcontainers>
                <authors>authors</authors>
                <baskets>baskets</baskets>
                <docservers>docservers</docservers>
                <doctypes>doctypes</doctypes>
                <extdocserver>ext_docserver</extdocserver>
                <fulltext>fulltext</fulltext>
                <groupbaskets>groupbasket</groupbaskets>
                <groupsecurity>groupsecurity</groupsecurity>
                <history>history</history>
                <param>parameters</param>
                <resgroups>resgroups</resgroups>
                <resgroupcontent>resgroup_content</resgroupcontent>
                <security>security</security>
                <usergroups>usergroups</usergroups>
                <usergroupcontent>usergroup_content</usergroupcontent>
                <users>users</users>
        </TABLENAME>


vérifie que tu ais bien la même liste avant d'écraser tout ça ;-)
++



J'ai pas pensé au config.xml ...
--> J'ai fait la modif ça marche

Merci ! :-)
yarow
 
Message(s) : 3
Inscription : 20 Sep 2008, 01:38


Retour vers Installation (Maarch 2.x)

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)

cron