Le navigateur ne s'ouvre pas avec mcc_client

Le connecteur entre votre scanner, votre pc et les applications Maarch
The link between your scanner, your Pc, and Maarch solutions

Le navigateur ne s'ouvre pas avec mcc_client

Message par totof82 » 03 Fév 2012, 09:34

Bonjour,

Lorsque je me met en mode "mass_scan" et que je depose un fichier pdf sur mon fichier launch_mcc_client_mlb.bat. L'application maarch me demande un compte utilisateur et lorsque je me logue, il ne m'ouvre pas le document dans maarch. J'ai vu dans un post sur le forum que cela dependait du fichier mcc_client.php, ne connaissant pas le php, je vous fais parvenir un extrait du fichier qui concerne le lancement du browser dans maarch. Pouvez vous me dire si il y a un problème à ce niveau. Merci

* Open Maarch Application with the sended file
*/
function openMaarchApplication()
{
$urlParams = retrieveProperties($_ENV['fileToProcess']);
sendDocument();
writeLog("\"".$_ENV['browserPath']."\" \"".$_ENV['maarchUrl'].$urlParams."\"");
$command = " start \"".$_ENV['browserPath']."\" \"".$_ENV['maarchUrl'].$urlParams."\"";
//$command = " start \"".$_ENV['maarchUrl'].$urlParams."\"";
$batFile = $_ENV["mccPath"].DIRECTORY_SEPARATOR."os_scripts".DIRECTORY_SEPARATOR."tmp_script.bat";
$inF = fopen($batFile,"w");
fwrite($inF,$command);
fclose($inF);
$converter_result = exec($batFile, $return_var);
//unlink($batFile);
}
totof82
 
Message(s) : 20
Inscription : 04 Jan 2012, 09:51

Re: Le navigateur ne s'ouvre pas avec mcc_client

Message par totof82 » 06 Fév 2012, 14:50

Quelqu'un pourrait-il m'aider ?

Merci
totof82
 
Message(s) : 20
Inscription : 04 Jan 2012, 09:51

installation et documentation ...

Message par totof82 » 07 Fév 2012, 10:31

A la demande de mon Directeur, je dois évaluer la solution Maarch Letterbox et Capture Connector client et serveur, pour une mise en oeuvre sous Linux. Il s'avère que la documentation mise à disposition par Maarch concerne des environnements windows. Afin d'aboutir ce projet, je dois obtenir quelques réponses et je suis surpris du silence de ce forum. Dommage qu'un produit "séduisant" et opensource ne puisse être installé dans un environnement "libre" : je communiquerai cependant les solutions aux premières difficultés rencontrées, j'espère que d'autres ont réussi leur installation...
totof82
 
Message(s) : 20
Inscription : 04 Jan 2012, 09:51

Re: Le navigateur ne s'ouvre pas avec mcc_client

Message par sna » 20 Fév 2012, 14:03

Bonjour,

1. Que souhaitez-vous faire exactement? (Pourquoi choisir le mode mass_scan?)
2. Avez-vous un message d'erreur?
3. Les fichiers de configuration sont-ils corrects?
sna
 
Message(s) : 51
Inscription : 27 Sep 2010, 10:45

Re: Le navigateur ne s'ouvre pas avec mcc_client

Message par totof82 » 22 Fév 2012, 09:31

Bonjour,

je souhaite pouvoir faire un import en masse de documents via mon scanner et que ces derniers soient envoyés dans l'application letterbox ?

je souhaite aussi pouvoir envoyer des documents au format pdf de mon poste client qui est sous seven vers maarch letter box.

Ci joint mon fichier config_mlb.xml qui se trouve sur le client :


<ROOT>
<CONFIG>
<CONFIG_NAME>mlb</CONFIG_NAME> <!-- keyword of the config file on mcc server -->
<MCC_PATH>C:\MCC_Client-1.1\</MCC_PATH> <!-- path of mcc client -->
<SCAN_IMPORT_PATH>C:\MCC_Client-1.1\incoming</SCAN_IMPORT_PATH> <!-- path of images (output of scan or virtual printer) -->
<MAARCH_URL>http://gest-courrier.cg82.local/courrier_test/index_scansnap.php</MAARCH_URL> <!-- URL of maarch to launch, disabled in mcc mass scan mode -->
<UPLOAD_URL>http://gest-courrier.cg82.local/MCC_Server-1.1/mcc_server.php</UPLOAD_URL> <!-- URL of mcc server, used to upload images -->
<GET_DATAS_URL>http://gest-courrier.cg82.local/MCC_Server-1.1/get_datas.php</GET_DATAS_URL> <!-- URL of mcc server, used to retrieve datas, enabled in mcc form mode -->
<WEB_PORT></WEB_PORT> <!-- port of mcc server -->
<SSL_CERT></SSL_CERT> <!-- path of certificate for ssl mode -->
<URL_PROXY></URL_PROXY> <!-- url_proxy:port_proxy --> <!-- http://192.168.0.2:3128/ -->
<USER_PROXY></USER_PROXY> <!-- domain_if_necessary\\username_proxy:pwd_proxy --> <!-- \\MAARCH\user:password -->
<AUTH_TYPE_PROXY></AUTH_TYPE_PROXY> <!-- CURLAUTH_BASIC or CURLAUTH_NTLM-->
<TYPE_PROXY></TYPE_PROXY> <!-- CURLPROXY_HTTP or CURLPROXY_SOCKS5 -->
<BROWSER_PATH>C:\Program Files\Mozilla Firefox\firefox.exe</BROWSER_PATH> <!-- path of the browser, here Mozilla Firefox -->
<!-- <BROWSER_PATH>C:\Program Files\Internet Explorer\iexplore.exe</BROWSER_PATH> --> <!-- path of the browser, here Internet Explorer -->
</CONFIG>
<FORM>
<FORM_MODE>false</FORM_MODE> <!-- true if you want to use form -->
<MASS_SCAN>true</MASS_SCAN> <!-- if you use mcc with a massive scanner -->
<IMAGE_FORMAT>pdf</IMAGE_FORMAT> <!-- only for mass scan mode, put ALL if you want to retrieve all format (not recommanded)-->
<IS_FOR_MLB>true</IS_FOR_MLB> <!-- true if target is letterbox -->
</FORM>
</ROOT>



Sur le serveur j'ai installé maarch letter box 2.8/maarch autoimport/mcc server.

J'ai configuré mon fichier config.xml de letterbox de la façon suivante :

<!-- Paramètres généraux -->
<MaarchURL>http://gest-courrier.cg82.local/courrier_test/</MaarchURL><!-- Url de l'application -->
<applicationname>Gestion du courrier</applicationname><!-- Nom de l'application -->
<adminmail>monadressemail</adminmail><!-- mail de l'administrateur de maarch -->
<adminname>Administrateur Maarch</adminname><!-- nom de l'administrateur maarch -->

<!-- Connexion à la base de données Mysql -->
<databaseserver>ipduserveur</databaseserver> <!-- serveur de base données -->
<databasename>maarch_letterbox_test</databasename> <!-- nom de la base de données -->
<databaseuser>root</databaseuser><!-- utilisateur de la base de données -->
<databasepassword></databasepassword><!-- mot de passe de la base de données -->

<!-- Répertoires de l'application LetterBox -->
<tmpdir>tmp</tmpdir>
<includedir>include</includedir>
<ldap_directory>ldap2</ldap_directory>
<xmlpath>xml</xmlpath><!-- répertoire où sont stockés les fichiers de config xml -->
<img>img</img>

<!-- Gestion des CSS -->
<css>css/styles.css</css> <!-- Chemin du fichier css de Maarch-->
<css_ie>css/style_ie.css</css_ie>
<css_ie7>css/style_ie7.css</css_ie7>

<!-- Paramétrage complémentaires-->
<exportlist>xml/export.xml</exportlist>
<ldap_config_path>ldap2/config_ldap.xml</ldap_config_path>
<path_to_lucene_index>full_text/indexes</path_to_lucene_index>
<ez_components_path>webdav/ezcomponents-2009.2.1</ez_components_path>
<webdav_content>webdav/content/</webdav_content>
<webdav_url>webdav/letterbox/index.php</webdav_url>
<webdav_reserved_time>30</webdav_reserved_time>

<!-- Configuration avancée de la solution -->
<nblinetoshow>10</nblinetoshow><!-- nb de lignes pour les listes (recherche, admin, ...) -->
<limitcharsearch>2</limitcharsearch><!-- nb minimal de caracteres pour la recherche -->
<lang>fr</lang><!-- langue par défaut -->
<enabledadvsearch>true</enabledadvsearch><!-- autorisation de la recherche avancée -->
<enabledindexfile>true</enabledindexfile><!-- autorisation de l'indexation -->
<enabledvalidation>true</enabledvalidation><!-- autorisation de la validation de courrier -->
<enabledprocess>true</enabledprocess><!-- autorisation du traitement de courrier-->
<enablestats>true</enablestats><!-- autorisation de la visualisation des statistiques -->
<shortcut>false</shortcut><!-- autorisation des raccourcis pour la recherche rapide -->
<debug>false</debug><!-- debug -->
<defaultPage>welcome</defaultPage>
<CookieTime>60</CookieTime><!-- minutes -->
<force_client_utf8>true</force_client_utf8>
<ldap>false</ldap>

J'ai configuré mon fichier config_letterbox.xml de maarch autoimport de la façon suivante :

<CONFIG>
<CONFIG_NAME>letterbox</CONFIG_NAME>
<MAPPING_FILE>/var/www/html/MaarchAutoImport-3.2/maarch_autoimport/mapping_letterbox.xml</MAPPING_FILE>
<SCAN_IMPORT_DIRECTORY>/var/www/html/MCC_Server-1.1/outcome/</SCAN_IMPORT_DIRECTORY>
<LOCATION>IPSERVEUR</LOCATION>
<DATABASE_PORT>3306</DATABASE_PORT>
<DATABASE>maarch_letterbox_test</DATABASE>
<DATABASETYPE>MYSQL</DATABASETYPE>
<DATABASEWORKSPACE></DATABASEWORKSPACE>
<USER_NAME>root</USER_NAME>
<PASSWORD></PASSWORD>
<TABLE_NAME>res_x</TABLE_NAME>
<INSERT_MODE>false</INSERT_MODE>
<DOCSERVER_NAME>letterbox_ai</DOCSERVER_NAME>
<DATE_TIME_FORMAT>YYYY-MM-DD</DATE_TIME_FORMAT>
<AUTO_IMPORT_DIRECTORY>/var/www/html/MCC_Server-1.1/outcome/</AUTO_IMPORT_DIRECTORY>
<WITHOUT_XML>true</WITHOUT_XML>
<BACKUP_BATCH>true</BACKUP_BATCH>
<EXCLUDE_EXISTING_DOCS>false</EXCLUDE_EXISTING_DOCS>
<EXCLUDE_EXISTING_DOCS_FOLDER>duplicate</EXCLUDE_EXISTING_DOCS_FOLDER>
<CREATE_FOLDERS>true</CREATE_FOLDERS>
<FOLDERS_TABLE_NAME>folders</FOLDERS_TABLE_NAME>
<FOLDERS_MAPPING_FILE>MaarchAutoImport-3.2/maarch_autoimport/mapping_folders.xml</FOLDERS_MAPPING_FILE>
</CONFIG

J'ai configuré mon fichier config.xml de letterbox de la façon suivante :

<CONFIG>
<CONFIG_NAME>mlb</CONFIG_NAME>
<MCC_PATH>MCC_Server-1.1/</MCC_PATH> <!-- path of mcc server -->
<MAARCH_TMP_PATH>courrier_test/tmp/</MAARCH_TMP_PATH> <!-- disabled in form mode, tmp path of maarch -->
<TARGET_PATH>MCC-Server-1.1/outcome/</TARGET_PATH> <!-- enabled in form, incoming path of preprocess or AutoImport -->
<FORM>MCC_Server-1.1/config/form_mlb.xml</FORM> <!-- mcc client form -->
<CREATE_INDEX>true</CREATE_INDEX> <!-- true if you want to create index xml file -->
<STRUCTURE_FILE>MCC_Server-1.1/config/structure_mlb.xml</STRUCTURE_FILE> <!-- mandatory if create index-->
</CONFIG>
<DATABASE> <!-- database connection -->
<LOCATION>IPSERVEUR</LOCATION>
<DATABASE_PORT>3306</DATABASE_PORT>
<DATABASE>maarch_letterbox_test</DATABASE>
<DATABASETYPE>MYSQL</DATABASETYPE>
<DATABASEWORKSPACE></DATABASEWORKSPACE>
<USER_NAME>root</USER_NAME>
<PASSWORD></PASSWORD>
</DATABASE

J'ai certainement du faire des erreurs au niveau de mes fichiers de conf, pouvez vous m'aiguiller svp. Merci

Cordialement
totof82
 
Message(s) : 20
Inscription : 04 Jan 2012, 09:51

Re: Le navigateur ne s'ouvre pas avec mcc_client

Message par ari » 15 Juil 2013, 11:28

Bjr tout le monde;je suis entrain de parametrer Maarch entreprise 1.4, ca marche bien.
maintenant j'ai un probleme avec le MCC client,si je scanne un doc,il ouvre le navigateur,et il menvoie un message PROBLEM DURING FILE SEND si <MASS_SCAN>true</MASS_SCAN>.
je vous demande une aide.
ari
 
Message(s) : 1
Inscription : 12 Juil 2013, 18:53

Re: Le navigateur ne s'ouvre pas avec mcc_client

Message par Kamilla » 29 Oct 2015, 17:30

This is very nice and cool post tahsnk for this ..........!!!!!!!!!!!!!!!!!!!!!!!!
Kamilla
 
Message(s) : 14
Inscription : 29 Oct 2015, 16:40


Retour vers Maarch Capture Connector

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron