BUG module LDAP

Sujet de discussion sur vos développements spécifiques, améliorations possibles ou prototypes.

BUG module LDAP

Message par sdis974 » 09 Sep 2017, 11:59

Bonjour
Je test actuellement la solution maarch courrier en v17.06.5.

J'ai découvert un bug avec le module ldap. Mon objectif est d'interface notre outils avec notre annuaire AD.
Le paramétrage est OK - authentification OK.
En revanche la synchronisation des entité ne fonctionne pas.... elle ne provisionne qu'un seul des groupe AD.

Après vérification il y a un soucis dans le script process_entities_to_maarch.php ligne 178 :
Code : Tout sélectionner
$qry = $db->prepare("SELECT max(cast(substring(entity_id,5) as integer)) as id from entities order by id asc");

devrait être
Code : Tout sélectionner
$qry = $db->prepare("SELECT max(cast(substring(entity_id,5) as integer)) as id from entities where entity_id LIKE 'ldap%' order by id asc");


Bien cordialement
sdis974
 
Message(s) : 5
Inscription : 09 Sep 2017, 11:49

Re: BUG module LDAP

Message par faz » 11 Sep 2017, 09:16

Bonjour,
merci pour votre retour.
Après validation par nos équipes technique, nous intégrerons le correctif à la prochaine version mineure.
Cordialement,
Nos solutions :
maarchcourrier.com
maarchrm.com

Communauté : forge.maarch.org
Suivez nos développements : labs.maarch.org/maarchl
faz
 
Message(s) : 108
Inscription : 02 Mars 2015, 23:44
Localisation : Paris


Retour vers Développeurs

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité